Autor Tema: Problema con PHPMailer y SugarCRM (Linuxmint)  (Leído 1041 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado TK!

  • The Communiter-
  • *
  • Mensajes: 2478
Problema con PHPMailer y SugarCRM (Linuxmint)
« : marzo 22, 2017, 03:15:55 pm »
Alguien ha instalado y configurado sugarcrm???

Tengo problemas con phpmailer, no envía correos y se queda supuestamente enviando pero nada...

Desconectado g00mba

  • The Communiter-
  • *
  • Mensajes: 14583
  • SOMOS LEGION
    • ALABADO SEA MONESVOL
Re:Problema con PHPMailer y SugarCRM (Linuxmint)
« Respuesta #1 : marzo 22, 2017, 03:29:47 pm »
Alguien ha instalado y configurado sugarcrm???

Tengo problemas con phpmailer, no envía correos y se queda supuestamente enviando pero nada...
y... con que servidor de correo lo estas usando? ya revisaste el log de ese servidor? ya habilitaste el modo verboso de phpmailer?

Desconectado TK!

  • The Communiter-
  • *
  • Mensajes: 2478
Re:Problema con PHPMailer y SugarCRM (Linuxmint)
« Respuesta #2 : marzo 22, 2017, 03:35:05 pm »
y... con que servidor de correo lo estas usando? ya revisaste el log de ese servidor? ya habilitaste el modo verboso de phpmailer?
el servidor es propio de la empresa (webmail), no tengo acceso a esos logs, no he habilitado el modo verboso...

update: el encargado del servidor me dice q no aparecen registros de la cuenta con la q estoy probando
« Última Modificación: marzo 22, 2017, 04:02:08 pm por TK! »

Desconectado g00mba

  • The Communiter-
  • *
  • Mensajes: 14583
  • SOMOS LEGION
    • ALABADO SEA MONESVOL
Re:Problema con PHPMailer y SugarCRM (Linuxmint)
« Respuesta #3 : marzo 22, 2017, 04:06:16 pm »
asegurate que el servidor web tenga acceso al servidor de correos, un simple ping a la ip o URL deberia bastar. verificaste que el modo de correo que estas usando (que asumo es SMTP) esta de hecho habilitado en el servidor de correo, y habilitale el modo verboso a phpmailer y que escriba a algun archivo.

Desconectado TK!

  • The Communiter-
  • *
  • Mensajes: 2478
Re:Problema con PHPMailer y SugarCRM (Linuxmint)
« Respuesta #4 : marzo 23, 2017, 09:39:52 am »
Al final lo solucioné, solo era de pasar a false una pinche linea del class.phpmailer: SMTPAutoTLS

Citar
Description ¶

Since 5.2.10, PHPMailer has added a new feature to automatically use TLS encryption when available at the SMTP server side, via SMTPAutoTLS.
This setting is true by default which is kind of security feature but in real life this is causing headaches due to wrongly configured SMTP server with regards to TLS support (see e.g.: https://github.com/PHPMailer/PHPMailer/issues/642, https://github.com/PHPMailer/PHPMailer/issues/643).

That setting should be set to false to allow WP admin people to select TLS support only when it is actually supported by their SMTP server.