Autor Tema: Recompile Squid with SSL Bump Error  (Leído 1986 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado ernestoelunico

  • The Communiter-
  • *
  • Mensajes: 3086
  • Laa shay'a waqi'un Mutlaq bala kul'un mumkin
    • Cositas E-shop
Recompile Squid with SSL Bump Error
« : junio 15, 2017, 05:02:51 am »
Buen dia a todos

El dia de hoy me encuentra tonteando con este tutorial
https://docs.diladele.com/administrator_guide_4_1/system_configuration/https_filtering/recompile_squid.html?highlight=squid%20ssl%20bump

ya tengo funcionando mi  server listo instalado con la version de ubuntu 14.04

y hago todo el tutorial, con normalidad y funciona en cada paso hasta llegar a
Código: [Seleccionar]
$ cd squid3-3.3.8 && dpkg-buildpackage -rfakeroot -b
aca es donde empieza mi odisea llevo varias horas probando de todo y no se que esta mal. en la termina se empiza a hacer todo el proceso pero llega a un punto que parece que llega a un bucle un punto donde se vuelve cíclico y el sistema no sale no tira error no finaliza el proceso se queda ahi aparentemente dando vuelta una y otra vez sin poder avanzar.

No se si habra un master que me pueda iluminar que estoy haciendo mal

parece que el proceso era muy largo pero veo unos errores

dpkg-gencontrol: warning: package squid3: unused substitution variable ${perl:Depends}
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -psquid3 ; fi
dh_md5sums -psquid3
dh_builddeb -psquid3
dpkg-deb: warning: 'debian/squid3/DEBIAN/control' contains user-defined field 'Original-Maintainer'
dpkg-deb: warning: ignoring 1 warning about the control file(s)

dpkg-deb: building package `squid3' in `../squid3_3.3.8-1ubuntu6.9_amd64.deb'.
dh_gencontrol -psquid3-dbg
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -psquid3-dbg ; fi
dh_md5sums -psquid3-dbg
dh_builddeb -psquid3-dbg
dpkg-deb: warning: 'debian/squid3-dbg/DEBIAN/control' contains user-defined field 'Original-Maintainer'
dpkg-deb: warning: ignoring 1 warning about the control file(s)

dpkg-deb: building package `squid3-dbg' in `../squid3-dbg_3.3.8-1ubuntu6.9_amd64.deb'.
dh_gencontrol -psquidclient
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -psquidclient ; fi
dh_md5sums -psquidclient
dh_builddeb -psquidclient
dpkg-deb: warning: 'debian/squidclient/DEBIAN/control' contains user-defined field 'Original-Maintainer'
dpkg-deb: warning: ignoring 1 warning about the control file(s)

dpkg-deb: building package `squidclient' in `../squidclient_3.3.8-1ubuntu6.9_amd64.deb'.
dh_gencontrol -psquid-cgi
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -psquid-cgi ; fi
dh_md5sums -psquid-cgi
dh_builddeb -psquid-cgi
dpkg-deb: warning: 'debian/squid-cgi/DEBIAN/control' contains user-defined field 'Original-Maintainer'
dpkg-deb: warning: ignoring 1 warning about the control file(s)

dpkg-deb: building package `squid-cgi' in `../squid-cgi_3.3.8-1ubuntu6.9_amd64.deb'.
dh_gencontrol -psquid-purge
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -psquid-purge ; fi
dh_md5sums -psquid-purge
dh_builddeb -psquid-purge
dpkg-deb: warning: 'debian/squid-purge/DEBIAN/control' contains user-defined field 'Original-Maintainer'
dpkg-deb: warning: ignoring 1 warning about the control file(s)

dpkg-deb: building package `squid-purge' in `../squid-purge_3.3.8-1ubuntu6.9_amd64.deb'.
dh_gencontrol -psquid
# only call dh_scour for packages in main
if grep -q '^Component:[[:space:]]*main' /CurrentlyBuilding 2>/dev/null; then dh_scour -psquid ; fi
dh_md5sums -psquid
dh_builddeb -psquid
dpkg-deb: warning: 'debian/squid/DEBIAN/control' contains user-defined field 'Original-Maintainer'
dpkg-deb: warning: ignoring 1 warning about the control file(s)

dpkg-deb: building package `squid' in `../squid_3.3.8-1ubuntu6.9_amd64.deb'.
 dpkg-genchanges -b >../squid3_3.3.8-1ubuntu6.9_amd64.changes
dpkg-genchanges: binary-only upload - not including any source code
 dpkg-source --after-build squid3-3.3.8
dpkg-buildpackage: binary only upload (no source included)



« Última Modificación: junio 15, 2017, 05:28:41 am por ernestoelunico »

Desconectado g00mba

  • The Communiter-
  • *
  • Mensajes: 14583
  • SOMOS LEGION
    • ALABADO SEA MONESVOL
Re:Recompile Squid with SSL Bump Error
« Respuesta #1 : junio 15, 2017, 09:33:17 am »
ahi no veo ningun error ...? puros warnings...

Desconectado ernestoelunico

  • The Communiter-
  • *
  • Mensajes: 3086
  • Laa shay'a waqi'un Mutlaq bala kul'un mumkin
    • Cositas E-shop
Re:Recompile Squid with SSL Bump Error
« Respuesta #2 : junio 16, 2017, 10:26:20 am »
ahi no veo ningun error ...? puros warnings...
lo hice todo y no me jalo no se que rayos hice mal pero no me conecta el proxy

Desconectado g00mba

  • The Communiter-
  • *
  • Mensajes: 14583
  • SOMOS LEGION
    • ALABADO SEA MONESVOL
Re:Recompile Squid with SSL Bump Error
« Respuesta #3 : junio 16, 2017, 12:25:26 pm »
lo hice todo y no me jalo no se que rayos hice mal pero no me conecta el proxy
esperate, pero entonces te compilo el paquete?

Desconectado ernestoelunico

  • The Communiter-
  • *
  • Mensajes: 3086
  • Laa shay'a waqi'un Mutlaq bala kul'un mumkin
    • Cositas E-shop
Re:Recompile Squid with SSL Bump Error
« Respuesta #4 : junio 18, 2017, 05:39:23 am »
esperate, pero entonces te compilo el paquete?
si logre compilar el paquete claro ajustando la verion del archivo pero al instalarlo no conectaba el proxy

Desconectado g00mba

  • The Communiter-
  • *
  • Mensajes: 14583
  • SOMOS LEGION
    • ALABADO SEA MONESVOL
Re:Recompile Squid with SSL Bump Error
« Respuesta #5 : junio 18, 2017, 04:57:38 pm »
Y al probar la versión normal de squid que pasa?

Desconectado ernestoelunico

  • The Communiter-
  • *
  • Mensajes: 3086
  • Laa shay'a waqi'un Mutlaq bala kul'un mumkin
    • Cositas E-shop
Re:Recompile Squid with SSL Bump Error
« Respuesta #6 : junio 19, 2017, 01:52:26 am »
Y al probar la versión normal de squid que pasa?

esa es la que uso y si me trabaja
pero queria esta para usar lo de ssl bump