Sv Community El Salvador

Soporte y Tecnología => Programación => Java => Mensaje iniciado por: hdavydc en mayo 19, 2016, 02:33:55 am

Título: Ayudaa
Publicado por: hdavydc en mayo 19, 2016, 02:33:55 am
Hola, me podrían ayudar necesito saber como encontrar el numero mayor y menor de una matriz de jtextfields, ya que he intentado varias veces y no encuentro como hacerlo.

código:
public class ModoG extends JFrame implements ActionListener{
        Container Contenedor=null;
   
        JTextField [][] valores = new JTextField[10][6]; 
       
        double mayor=0;
        double menor=0;
       
        ModoG(){
 for (int i = 0; i < valores.length; i++) {
                for (int j = 0; j < valores.length; j++) {
                    valores[j]=new JTextField();
                     valores[j].setBackground(new Color(91, 91, 95));
                      valores[j].setFont(new Font("Times New Roman", 0, 14));
                       valores[j].setForeground(new Color(255, 255, 255));
                        valores[j].setBounds((i+5)*75,(j+3)*64 , 62, 25);
                         valores[j].setEditable(false);
                          this.add(valores[j]);         
                }
            }
Título: Re:Ayudaa
Publicado por: Jonhyrey en mayo 19, 2016, 08:34:03 am
Te voy a poner el pseudo codigo:

Tu tarea va a ser interpretarlo y generarlo en el lenguaje de programacion que te han pedido de tarea:

Citar
Hola, eso es fácil la idea es hacer un ciclo repetitivo hasta el último número, y a medida que se lee el número se va comparando el valor leido con 2 variables llamadas MENOR y MAYOR, las cuales contendrán obviamente el valor mayor y menor de los números

Te voy a explicar con la sintáxis de pseudocódigo que manejo (las // son comentarios):

//antes que todo asumamos que ya leiste o generaste el valor de N

//Inicialmente el valor mayor es cero, es decir no existe un número mayor, por lo
//tanto al hacer la 1era comparación ese 1er número será el mayor
Mayor = 0
//Inicialmente el valor menor es un número muy grande por lo
//tanto al hacer la 1era comparación ese 1er número será el menor
Menor = 9999999999
//Se hace un ciclo repetitivo desde el 1er número hasta N
Para I=1 hasta N
//Se muestra un mensaje al usuario solicitando un número
Escribir "Indique el valor del número", I
//Se lee el número
Leer Num
//Si el valor leido es mayor que el valor almacenado
Si (Num>Mayor) entonces
//Ahora el nuevo número mayor es el leido
Mayor = Num
Fin Si
//Si el valor leido es menor que el valor almacenado
Si (Num<Menor) entonces
//Ahora el nuevo número menor es el leido
Menor = Num
Fin Si
Fin Para

Espero que haya sido de ayuda

Saludos


Ojala te sirva.

Fuente:
http://www.forosdelweb.com/f14/obtener-mayor-menor-valor-n-numeros-con-pseudocodigo-330346/ (http://www.forosdelweb.com/f14/obtener-mayor-menor-valor-n-numeros-con-pseudocodigo-330346/)
Título: Re:Ayudaa
Publicado por: salvadoresc en mayo 19, 2016, 08:52:57 am
si tuvieras un titulo mas descriptivo seria mas facil que recibieras ayuda. :D
Título: Re:Ayudaa
Publicado por: Charlie en mayo 19, 2016, 09:04:58 am
si tuvieras un titulo mas descriptivo seria mas facil que recibieras ayuda. :D
Si, yo cuando vi el tiulo ya habia agarrado el telefono para llamar al 911.

Enviado desde mi SGH-T699 mediante Tapatalk

Título: Re:Ayudaa
Publicado por: snake of persia en mayo 19, 2016, 09:05:34 am
Te voy a poner el pseudo codigo:

Tu tarea va a ser interpretarlo y generarlo en el lenguaje de programacion que te han pedido de tarea:


Exacto es de las formas mas sencillas de hacerlo, ya adaptarlo a tu codigo no tendria complicacion alguna, suerte.